#994 closed enhancement (fixed)

Secore gnomomic CRS missing and errors with add/update CRS

Reported by: bphamhuu Owned by: bphamhuu
Priority: minor Milestone: 9.2
Component: secore Version: development
Keywords: gnomonic, secore, moon Cc: pbaumann, dmisev, vmerticariu
Complexity: Medium

Description

As Dimitar suggested, I will open this ticket for the CRS named "gnomonic" that Ramiro has used to reproject the Moon data images (.tiff file).

in the Planet Server - 1, the SECORE need to be update by hand the XML file with content, to /var/lib/tomcat/webapps/secoredb, according to https://teamwork.jacobs-university.de:8443/confluence/pages/viewpage.action?pageId=107938507

<gml:GeodeticCRS xmlns:gml="http://www.opengis.net/gml/3.2" xmlns:xlink="http://www.w3.org/1999/xlink" gml:id="crs-ps1">
  <gml:identifier codeSpace="http://www.ietf.org/rfc/rfc3986">urn:ogc:def:crs:PS::1</gml:identifier>
  <gml:name>...</gml:name>
  <gml:scope>...</gml:scope>
  <gml:EllipsoidalCS xlink:href="urn:ogc:def:cs:EPSG::6422"/>
  <gml:GeodeticDatum gml:id="datum-ps1">
    <gml:identifier codeSpace="http://www.ietf.org/rfc/rfc3986">urn:ogc:def:datum:PS::1</gml:identifier>
    <gml:name>...</gml:name>
    <gml:remarks>...</gml:remarks>
    <gml:PrimeMeridian gml:id="meridian-ps1">
      <gml:identifier codeSpace="http://www.ietf.org/rfc/rfc3986">urn:ogc:def:meridian:PS::1</gml:identifier>
      <gml:name>...</gml:name>
      <gml:greenwichLongitude>
        <gml:angle gml:uom="urn:ogc:def:uom:EPSG::9102">0</gml:angle>
      </gml:greenwichLongitude>
    </gml:PrimeMeridian>
    <gml:Ellipsoid gml:id="ellipsoid-ps1">
      <gml:identifier codeSpace="http://www.ietf.org/rfc/rfc3986">urn:ogc:def:ellipsoid:PS::1</gml:identifier>
      <gml:name>...</gml:name>
      <gml:semiMajorAxis gml:uom="urn:ogc:def:uom:EPSG::9001">3396190</gml:semiMajorAxis>
      <gml:secondDefiningParameter>
        <gml:inverseFlattening gml:uom="urn:ogc:def:uom:EPSG::9201">0</gml:inverseFlattening>
      </gml:secondDefiningParameter>
    </gml:Ellipsoid>
  </gml:GeodeticDatum>
</gml:GeodeticCRS>

What I've done is using "Libre Office" and open the file named "GmlDictionary?.xml", add this XML content to the end of the file inside element gml:dictionaryEntry and reupdate SECORE EPSG Database with this tool:

http://212.201.45.10:8080/def/updatedb.jsp

After that, wcs-t import could ingest image with this CRS kind. If I don't do this, it will has a misunderstanding error.

  <ows:Exception exceptionCode="RuntimeError">
       <ows:ExceptionText>Runtime error while processing request</ows:ExceptionText>
   </ows:Exception>
   <ows:Exception exceptionCode="RuntimeError">
       <ows:ExceptionText>java.lang.ArithmeticException : BigInteger divide by zero</ows:ExceptionText>
   </ows:Exception>

</ows:ExceptionReport>

After I change the CRS to the new one I updated http://212.201.45.10:8080/def/crs/PS/0/1 it could import normally.


Here is mroe errors with SECORE:

Also, notice that the "Add new CRS" is not working, when I click to "Add new definition?" it just add a parameter before the current link

http://212.201.45.10:8080/def/browse.jsp#add=true

And if I need to update a CRS, although not change anything, just browse the CRS and click button 'save', a big error appear

http://212.201.45.10:8080/def/crs/EPSG/0/2000/browse.jsp

type Exception report

message javax.servlet.ServletException: InternalComponentError: Failed at querying the database

description The server encountered an internal error that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: javax.servlet.ServletException: InternalComponentError: Failed at querying the database
	org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:549)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:455)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	secore.web.SecoreFilter.doFilter(SecoreFilter.java:117)
root cause

javax.servlet.ServletException: InternalComponentError: Failed at querying the database
	org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:916)
	org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:845)
	org.apache.jsp.WEB_002dINF.browse_jsp._jspService(browse_jsp.java:239)
	org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:432)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	secore.web.SecoreFilter.doFilter(SecoreFilter.java:117)
root cause

InternalComponentError: Failed at querying the database
	secore.db.BaseX.query(BaseX.java:146)
	secore.db.BaseX.queryUser(BaseX.java:187)
	secore.db.BaseX.updateQuery(BaseX.java:165)
	secore.util.SecoreUtil.updateDef(SecoreUtil.java:60)
	org.apache.jsp.WEB_002dINF.browse_jsp._jspService(browse_jsp.java:121)
	org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:432)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	secore.web.SecoreFilter.doFilter(SecoreFilter.java:117)
root cause

org.basex.core.BaseXException: Stopped at line 25, column 18:
[XPST0003] Unexpected end of query: 'xmlns:xlink="ht...'.
	org.basex.core.Command.execute(Command.java:73)
	org.basex.core.Command.execute(Command.java:85)
	secore.db.BaseX.query(BaseX.java:134)
	secore.db.BaseX.queryUser(BaseX.java:187)
	secore.db.BaseX.updateQuery(BaseX.java:165)
	secore.util.SecoreUtil.updateDef(SecoreUtil.java:60)
	org.apache.jsp.WEB_002dINF.browse_jsp._jspService(browse_jsp.java:121)
	org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:432)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	secore.web.SecoreFilter.doFilter(SecoreFilter.java:117)

This is for your information. Thanks Dimitar for supporting.

Change History (2)

comment:1 Changed 16 months ago by dmisev

  • Owner changed from dmisev to bphamhuu
  • Status changed from new to assigned

comment:2 Changed 16 months ago by bphamhuu

  • Resolution set to fixed
  • Status changed from assigned to closed

patch was accepted -> close.

Note: See TracTickets for help on using tickets.