Opened 2 years ago

Closed 21 months ago

#946 closed defect (fixed)

rasnet seems to ignore RMANPROTOCOL, rasmgr.conf

Reported by: pbaumann Owned by: atoader
Priority: major Milestone: 10.0
Component: rnprotocol Version: development
Keywords: Cc:
Complexity: Medium

Description

  • rasmgr.conf does not document any -type value for rasnet
  • rasnet cannot be set by RMANPROTOCOL

Change History (16)

comment:1 Changed 2 years ago by dmisev

  • Milestone set to 10.0
  • Owner changed from dmisev to atoader
  • Status changed from new to assigned

comment:2 Changed 2 years ago by atoader

What is the expected behavior? From what I remember, we talked a few times about this issue and we decided that, because rasmgr was rewritten, the protocol will be configured at compile time.
The -type parameter is ignored.

comment:3 Changed 2 years ago by dmisev

I remember the same as well.

comment:4 Changed 2 years ago by pbaumann

right, everytime I look at it it springs into my eyes :) Seriously, I'd ask to get rasnet to become the only protocol in the very near future. The current state is an inbetween which just confuses users. Anytime you have it ready I will adjust documentation.

comment:5 Changed 2 years ago by dmisev

I don't think it's ready yet, I haven't managed to actually get rasdaman with rasnet running yet (zmq strangely segfaults).

comment:6 Changed 2 years ago by atoader

I have not had a segfault in the last 4 months. What version of ZMQ did you install? Did you install it from the source code or from the repo? Please set up a VM where the segfault it is reproduced and give me access. Thanks!

comment:7 Changed 2 years ago by dmisev

It's on Debian 8.0, libzmq3 4.0.5+dfsg-2 from the official Debian repo (the guide says zmq >= 4.0.5 so I assume the version is fine).

comment:8 Changed 2 years ago by atoader

The version should be fine, but it isn't. As per the documentation, they should be installed from source. Try it out and let me know.

comment:9 Changed 2 years ago by dmisev

I followed the guide here, it doesn't say that it has to be installed from source: http://rasdaman.org/wiki/Install#rasnetcommunicationprotocol

Anyway I'll try that, and the guide needs to be updated.

comment:10 Changed 2 years ago by atoader

For Ubuntu and Debian users:

Install protobuf and boost dependencies:

sudo apt-get install libprotobuf-dev libprotobuf-java libboost-all-dev
For ZeroMQ download ​ZeroMQ 4.0.5 and ​ZeroMQ Java bindings and install them from sources and then run:

sudo ldconfig.

We should mark the last part as important.

comment:11 Changed 2 years ago by dmisev

Ah right, it'd down there and I didn't even notice it :) Great, and yes, that should be made a bit more prominent.

comment:12 Changed 2 years ago by dmisev

Btw, rasdaman with rasnet takes some serious long time and a lot of CPU to compile for me, do you experience the same? At some point it got stuck on compiling some seemingly small file, and all I could think is that there is some bug with gcc.

comment:13 Changed 2 years ago by pbaumann

the need for compiling from source introduces an extra installation complexity. The detailed steps (commands) should be listed on the how-to page. Also, would it make sense to distribute the source as part of the rasdaman code (ie, clone their repo), and update there whenever necessary?

comment:14 Changed 2 years ago by atoader

The long compilation time is due to Boost.Spirit which we use for parsing the rascontrol commands. Boost.Spirit relies heavily on templates and meta-programming, and this takes longer to compile.

We also thought about including the ZMQ source code in rasdaman in some for or another.
I am not sure if the license allows it. Could somebody take a look at : http://zeromq.org/area:licensing and advise?

comment:15 Changed 2 years ago by pbaumann

hm, looks good to me, but Dimitar might check as well - more eyes...

comment:16 Changed 21 months ago by dmisev

  • Resolution set to fixed
  • Status changed from assigned to closed

This seems outdated to me so closing.

Note: See TracTickets for help on using tickets.