Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#720 closed enhancement (fixed)

ps_service_provider has column contact_role that should be constrained against a dictionary of values

Reported by: jpass Owned by: pcampalani
Priority: minor Milestone: 9.0.x
Component: petascope Version: development
Keywords: petascopedb Cc:
Complexity: Easy

Description (last modified by jpass)

The value of contact_role in the table ps_service_provider is used to populate the ows:Role of the WCS GetCapabilities? response. This role has a restriction in the XML schema to a code list defined by section B5.5 (CI_RoleCode) of ISO 19115:2003.

It would be nice if petascopedb could have some dictionary of the allowed values, that could be used to constrain the values in ps_service_provider

Incidentally, the default value supplied in the table currently ('Project leader') is not a valid value, a more appropriate default would be 'pointOfContact'

The value of 'Project leader' would better be applied to the 'contact_position_name' column in the same table.

Change History (7)

comment:1 Changed 3 years ago by jpass

  • Description modified (diff)

comment:2 Changed 3 years ago by jpass

It appears that the value of key WCS_PROVIDER_CONTACT_ROLE in petascopedb table ps_string_constants is providing the invalid 'Project Leader' string here. I'm not sure if this an invalid mapping, i.e. whether it was intended that this value should populate the contact_position_name in ps_service_provider, or whether it was indeed intended to populate the contact_role; if the latter is intended this string should change to pointOfContact (sic).

comment:3 Changed 3 years ago by abeccati

  • Complexity changed from Medium to Easy
  • Component changed from undecided to petascope
  • Milestone set to 9.1
  • Owner changed from dmisev to pcampalani
  • Status changed from new to assigned

comment:4 Changed 3 years ago by pcampalani

  • Status changed from assigned to accepted

comment:5 Changed 3 years ago by pcampalani

Role code dictionary added in changeset:5530480 (requires update_petascopedb.sh).
James let me know as usual, thanks.

petascopedb=# SELECT * FROM ps_role_code;
 id |         value         |                                                          description                                                           
----+-----------------------+--------------------------------------------------------------------------------------------------------------------------------
  1 | resourceProvider      | party that supplies the resource
  2 | custodian             | party that accepts accountability and responsability for the data and ensures appropriate care and maintenance of the resource
  3 | owner                 | party that owns the resource
  4 | user                  | party who uses the resource
  5 | distributor           | party who distributes the resource
  6 | originator            | party who created the resource
  7 | pointOfContact        | party who can be contacted for acquiring knowledge about or acquisition of the resource
  8 | principalInvestigator | key party responsible for gathering information and conducting research
  9 | processor             | party who has processed the data in a manner such that the resource has been modified
 10 | publisher             | party who published the resource
 11 | author                | party who authored the resource
(11 rows)

REF: http://www.isotc211.org/2005/resources/Codelist/gmxCodelists.xml

comment:6 Changed 3 years ago by dmisev

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:7 Changed 3 years ago by dmisev

  • Milestone changed from 9.1 to 9.0.x
Note: See TracTickets for help on using tickets.