Opened 4 years ago

Closed 4 years ago

#675 closed defect (fixed)

Portability problem with PostgreSQL prior to 9.1 on literals

Reported by: pcampalani Owned by: pcampalani
Priority: critical Milestone: 9.0.x
Component: petascope Version: development
Keywords: postgresql literal backslash Cc: dmisev
Complexity: Easy

Description

Since PostgreSQL 9.1 backslashes are treated literally in literals: this is not true however in previous versions of Postgres, thus creating a portability problem for users using 8.X or prior versions of Postgres.

The variable 'standard_conforming_strings' should be then set before starting the update of petascopedb.

See this page in the PostgreSQL documentation.

Change History (2)

comment:1 Changed 4 years ago by pcampalani

  • Status changed from new to accepted
  • Summary changed from Portability problem with PostgreSQL prio to 9.1 on literals to Portability problem with PostgreSQL prior to 9.1 on literals

comment:2 Changed 4 years ago by pcampalani

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in changeset:4816e4b.

Note: See TracTickets for help on using tickets.