Opened 3 years ago

Closed 22 months ago

#629 closed defect (invalid)

WCS 1.1 Wrong request gives wrong error message about version

Reported by: abeccati Owned by: pcampalani
Priority: minor Milestone:
Component: petascope Version: 8.5
Keywords: Cc:
Complexity: Trivial

Description

A request with a wrong request parameter leads to a misleading error message.

The following request to petascope/wcs?SERVICE=WCS&VERSION=1.1&REQUEST=GetCapability?

Gives the error trace below

TRACE [15:34:13] PetascopeInterface@234?: GET Query string : SERVICE=WCS&VERSION=1.1&REQUEST=GetCapability?
TRACE [15:34:13] PetascopeInterface@238?: Request parameters : {}
ERROR [15:34:13] PetascopeInterface@436?: Error stack trace:

InvalidRequest?: No WCS version specified.

at petascope.PetascopeInterface?.handleWcsRequest(PetascopeInterface?.java:513)

With error to the calling
<ows:Exception exceptionCode="InvalidRequest"><ows:ExceptionText>No WCS version specified.</ows:ExceptionText></ows:Exception>

Correct response has to indicate problem with unknown request parameter.

Discovered in 8.5.2

Change History (1)

comment:1 Changed 22 months ago by dmisev

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.