Opened 4 years ago

Closed 4 years ago

#565 closed defect (fixed)

Coverage description template for non-gridded coverages to be established

Reported by: pcampalani Owned by: pcampalani
Priority: major Milestone: 9.0
Component: petascope Version: development
Keywords: multipoint dimension attribute Cc: arezaeim
Complexity: Easy

Description

The schema definition does not allow a dimension attribute in the gml:MutliPoint element of a multipoint coverage. It is optional for gridded coverages, but does not have a meaning for multi* ones.

...
  <domainSet>
-   <MultiPoint dimension="3" gml:id="Parksmall-grid">
+   <MultiPoint gml:id="Parksmall-grid">
    <limits>
    ...
</domainSet>
...

On the other side, attributes from the group gml:SRSReferenceGroup would be useful, like is currently achieved in the gml:BoundedBy element.

Change History (2)

comment:1 Changed 4 years ago by pcampalani

  • Summary changed from gml:Multipoint do not have @dimension attribute to Coverage description template for non-gridded coverages to be established

The problem is actually different here: the MultiPoint template is right but the CoverageDescription template is valid only for gridded coverages, so the template itself must either change name to GridCoverageDescription otherwise the domainSet must be exported to sub-templates for different kinds of coverages.

As a side note, the CRS of MultiPoint coverages is hardwired to EPSG:4979 (which is wrong anyway, see #557) in the templates, and needs to be parametrized as all the other variables.

Last edited 4 years ago by pcampalani (previous) (diff)

comment:2 Changed 4 years ago by pcampalani

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in changeset:10c8884 (the whole package of templated petascope.wcs2.templates has been refactored, see changeset:59428a1 and related ticket #572).

Note: See TracTickets for help on using tickets.