Opened 3 years ago

Closed 3 years ago

#492 closed defect (fixed)

inv_tiff fails with rasj

Reported by: dmisev Owned by: dmisev
Priority: major Milestone: 9.0
Component: java Version: 8.5
Keywords: Cc: dirk.daems@…, pbaumann
Complexity: Medium

Description

reported by Dirk Daems on rasdaman-users:

The use of the inv_tiff() converter in a RASQL query executed using the RASJ API also generates an error. However, If I add the same TIFF file using the same commands via the RASQL command-line client, the file is uploaded correct.

org.odmg.QueryException: Execution error 381 in line 1, column 34, near token inv_tiff: Error in convertor of the selected data exchange format.
   at rasj.odmg.RasOQLQuery.execute(RasOQLQuery.java:238)
   at CreateCollection.main(CreateCollection.java:42)

Attachments (1)

UpdateTest.java (4.4 KB) - added by dmisev 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by dmisev

  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this issue. It sounds like the tiff file is incorrectly read. Does it work with PNG?

Here is a test which demonstrates how it works with PNG (but I tested with TIFF as well): source:java/src/tests/UpdateTest.java

To run it execute make tests in source:java

I'll close the ticket as invalid, please reopen if you still have a problem, but please attach an example that could be used to reproduce it.

comment:2 Changed 3 years ago by dirk.daems@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Could you try using the mean_summer_airtemp tiff packaged with Rasdaman? Just modify the file reference, inv_png -> inv_tiff in the RASQL query and the TESTDATA_SDOM and TESTDATA_SIZE statics.
It doesn't work for me although the same RASQL commands ingest the TIFF file fine when using the RASQL commandline tool.

comment:3 Changed 3 years ago by dmisev

Works fine for me, see attachement for the mean_summer_airtemp.tif test, can you test with this?

Changed 3 years ago by dmisev

comment:4 Changed 3 years ago by dirk.daems@…

Tried with a newer version and now seems to work as expected.
Ticket can be closed.

comment:5 Changed 3 years ago by dmisev

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.