Opened 4 years ago

Closed 4 years ago

#472 closed defect (fixed)

no 'request' Parameter for WCS

Reported by: j.yu Owned by: dmisev
Priority: major Milestone:
Component: petascope Version: 8.5
Keywords: Cc: pcampalani
Complexity: Medium

Description

The WCS post test fails due to the check for 'request' parameter

This check results in 'Bad Post Parameter' Exception for WCS Post 1.0 test. This 'request' parameter is not in the spec.

Attachments (1)

log (3.4 KB) - added by j.yu 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by j.yu

comment:1 Changed 4 years ago by dmisev

  • Cc pcampalani added

Piero is this still valid? You said the OGC test passes.

comment:2 Changed 4 years ago by pcampalani

It would be good to know which req. is this ticket targeting..
I tested KVP compliance to WCS service (revision r5 -- latest -- of the testsuite), whereas requirements 1 to 24 fail for SOAP and XML protocols.

In many (or maybe all) of the XML tests, I see the problem is:

Bad Post parameter '<?xml version', expected parameters are 'query'/'request'

Whereas for SOAP I see a lot of:

Error in call to extension function {public org.w3c.dom.NodeList com.occamlab.te.TECore.soap_request(org.w3c.dom.Document,java.lang.String) throws java.lang.Throwable}: Exception in extension function java.lang.reflect.InvocationTargetException

As far as I understood XML (and SOAP) are going to be deprecated and even removed from the available protocols, so I didn't investigate those errors.

comment:3 Changed 4 years ago by dmisev

I think we can close it now?

comment:4 Changed 4 years ago by pcampalani

  • Resolution set to fixed
  • Status changed from new to closed

Yes, see #561.

Note: See TracTickets for help on using tickets.