Opened 4 years ago

Closed 2 years ago

Last modified 2 years ago

#462 closed defect (invalid)

Classes r_Bag and r_List from API document don't actually exist?

Reported by: hholzgra Owned by: pbaumann
Priority: minor Milestone: 9.0.x
Component: manuals_and_examples Version: 8.5
Keywords: Cc:
Complexity: Medium

Description

Only mention of these two names is in ./rasodmg/collection.hh in a Doxygen comment:

./rasodmg/collection.hh:47: \Ref{r_Bag} and \Ref{r_List}. The protected members isOrdered and

and in the bundled .doc and .pdf versions of dev-guide-c++

How to reproduce: after a fresh checkout do:

$ cd rasdaman
$ grep -rni r_Bag .
./rasodmg/collection.hh:47: \Ref{r_Bag} and \Ref{r_List}. The protected members isOrdered and
Binary file ./manuals_and_examples/manuals/pdf/dev-guide-c++.doc matches

The only container template from the documentation that actually seems to exist is r_Set as far as i can tell ...

Change History (6)

comment:1 Changed 4 years ago by hholzgra

Same with r_Any as far as I can tell ...

comment:2 Changed 4 years ago by hholzgra

Only r_Any occurrences in the source seem to be:

vagrant@precise64:~/rasdaman$ grep -r r_Any .
./rasdl/parse.cc: name ="r_Any";
Binary file ./manuals_and_examples/manuals/pdf/dev-guide-c++.doc matches

comment:3 Changed 2 years ago by dmisev

  • Component changed from undecided to manuals_and_examples
  • Milestone set to 9.0.x
  • Owner changed from dmisev to pbaumann
  • Status changed from new to assigned

Peter the documentation seems to be out of sync with the API.

comment:4 Changed 2 years ago by pbaumann

that is correct. The rasodmg library implements only that part of the ODMG standard which is relevant for rasdaman. See the doxygen comment in rasodmg/collection.hh: "Possible subclasses are...".

comment:5 Changed 2 years ago by pbaumann

  • Resolution set to invalid
  • Status changed from assigned to closed

comment:6 Changed 2 years ago by pbaumann

PS: thanks for your attentiveness!

Note: See TracTickets for help on using tickets.