Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#459 closed defect (fixed)

WCS GetCoverage broken

Reported by: dmisev Owned by: pcampalani
Priority: major Milestone: 9.0
Component: petascope Version: 8.5
Keywords: Cc:
Complexity: Medium

Description

WCS systemtest fails for most queries, with error

 ERROR [16:13:07] PetascopeInterface@436: Error stack trace:
RuntimeError: 
	at petascope.PetascopeInterface.handleWcs2Request(PetascopeInterface.java:619)
	at petascope.PetascopeInterface.handleWcsRequest(PetascopeInterface.java:516)
	at petascope.PetascopeInterface.doGet(PetascopeInterface.java:300)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:240)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:203)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:164)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:108)
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:558)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:379)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:242)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:259)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:237)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:281)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.NullPointerException
	at petascope.wcs2.extensions.GmlFormatExtension.handle(GmlFormatExtension.java:69)
	at petascope.wcs2.handlers.GetCoverageHandler.handle(GetCoverageHandler.java:50)
	at petascope.wcs2.handlers.GetCoverageHandler.handle(GetCoverageHandler.java:37)
	at petascope.wcs2.extensions.AbstractProtocolExtension.handle(AbstractProtocolExtension.java:68)
	at petascope.PetascopeInterface.handleWcs2Request(PetascopeInterface.java:585)
	... 20 more

Change History (3)

comment:1 Changed 4 years ago by pcampalani

The CRS extension was removed from the WCS extensions registry in changeset:3315a1.
The GetCoverage? requests were broken since CRSExtension objects were still created and referred to in through the code and needed to be cleared out.
Patch is pending!

comment:2 Changed 3 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by abeccati

  • Milestone changed from 9.0-beta1 to 9.0

Milestone 9.0-beta1 deleted

Note: See TracTickets for help on using tickets.