Opened 4 years ago

Closed 3 years ago

#450 closed defect (duplicate)

Test rasserver with limited amount of memory

Reported by: dmisev Owned by: dmisev
Priority: major Milestone: 9.0.x
Component: rasserver Version: 8.5
Keywords: Cc: damiano, pbaumann
Complexity: Medium

Description

In particular the issue is when ingesting data and RAM and swap is filled up. It seems like it fails silently and gets blocked into an infinite loop, using 100% CPU.

Change History (3)

comment:1 Changed 4 years ago by pbaumann

hm, mymalloc() throws an exception. Maybe it isn't caught? In this case we might introduce it to the big catch-all after each query. My wild guessing...

comment:2 Changed 4 years ago by dmisev

I think it happens between rasdaman and postgres, when committing the transaction.

comment:3 Changed 3 years ago by dmisev

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #783 I'd say.

Note: See TracTickets for help on using tickets.