Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#390 closed defect (fixed)

Compound CRSs with a parametrized CRS

Reported by: pcampalani Owned by: dmisev
Priority: critical Milestone: 9.0
Component: secore Version: 8.4
Keywords: compound crs parametrized Cc: dmisev
Complexity: Medium

Description

SECORE should keep the parametrized URL when reporting the CRSs the compose a compound CRS, otherwise the parametrization is lost and the raw target CRS is pointed.

E.g. AUTO(1.3):42001 targets EPSG:4326:

http://localhost:8090/def/crs-compound?

1=http://localhost:8090/def/crs?authority=AUTO%26version=1.3%26code=42001%26lon=10&
2=http://localhost:8090/def/crs?authority=EPSG%26version=0%26code=5715

but the default EPSG:4326 definition is reported in the response (see //componentReferenceSystem/@xlink:href):

<CompoundCRS ... >
  <metaDataProperty>
    <epsg:CommonMetaData>
      <epsg:type>compound</epsg:type>
    </epsg:CommonMetaData>
  </metaDataProperty>
  <scope>not known</scope>
  <identifier codeSpace="OGC">
http://localhost:8090/def/crs-compound?1=http://localhost:8090/def/crs?authority=AUTO%26version=1.3%26code=42001%26lon=10%262=http://localhost:8090/def/crs?authority=EPSG%26version=0%26code=5715
  </identifier>
  <name>WGS 84 / msl depth</name>
  <componentReferenceSystem xlink:href="http://www.opengis.net/def/crs/EPSG/0/4326"/>
  <componentReferenceSystem xlink:href="http://www.opengis.net/def/crs/EPSG/0/5715"/>
</CompoundCRS>

Change History (5)

comment:1 Changed 4 years ago by dmisev

Is it duplicate of #355 ?

comment:2 Changed 4 years ago by pcampalani

Oh yes.. I closed that, this explains the root of the problem.

comment:3 Changed 4 years ago by dmisev

  • Owner changed from mrusu to dmisev
  • Status changed from new to assigned

The problem is in the generic handler, the CRS def returned for a parameterized handler should have identifier that includes also the parameters

http://www.opengis.net/def/crs/EPSG/0/4326&lon=10

not just

http://www.opengis.net/def/crs/EPSG/0/4326

comment:4 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 4 years ago by pcampalani

Single URLs percent-encoded in changeset:547d6d1.

Note: See TracTickets for help on using tickets.