Opened 4 years ago

Closed 3 years ago

#357 closed task (fixed)

Implement `pow()' WCPS function

Reported by: pcampalani Owned by: dmisev
Priority: critical Milestone: 9.0
Component: petascope Version: 8.4
Keywords: pow unary Cc: pbaumann
Complexity: Medium

Description (last modified by abeccati)

Despite all exponentialExpr are implemented in Petascope (see WCPS standard Sec.7.1.17), only pow(C,p) function is missing, and should be implemented despite easily reproducible by means of sequences of products.

Pow is a unary expression (src/main/java/petascope/wcps/server/core/UnaryOperationCoverageExpr.java).

Examples:

for c in (mean_summer_airtemp)
   return encode(
      coverage averagesOverTime
      over     $T t(1:5)
      values   pow($T,3),
   "csv")
for c in (mean_summer_airtemp)
  return encode(
       pow(c[x:"CRS:1"(100:101),y:"CRS:1"(300)],3),
    "csv")

See how other similar operators are implemented, e.g. log, ln, exp.

Depends on #374

Change History (15)

comment:1 Changed 4 years ago by abeccati

  • Owner changed from abeccati to swingit
  • Status changed from new to assigned

Assigning that as initial easy task to familiarize with petascope code.

comment:2 Changed 4 years ago by dmisev

  • Cc pbaumann added
  • Complexity changed from Easy to Medium
  • Resolution set to fixed
  • Status changed from assigned to closed

There's no pow equivalent function in rasdaman, I guess that's why it wasn't implemented in petascope in the first place.

So the first task is to implement pow in rasdaman, and then in petascope.

comment:3 Changed 4 years ago by dmisev

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 4 years ago by abeccati

  • Description modified (diff)
  • Status changed from reopened to assigned

Opened ticket for rasdaman component (#374), this one will only address petascope component for WCPS compliance.

comment:5 Changed 4 years ago by dmisev

Patch for rasql has been submitted, how is implementation in petascope progressing?

comment:6 Changed 4 years ago by abeccati

  • Milestone changed from Future to 8.4.3

comment:7 Changed 4 years ago by dmisev

  • Milestone changed from 8.4.3 to 8.4.4

comment:8 Changed 4 years ago by dmisev

  • Milestone changed from 8.4.4 to 8.5

Marco, what's the status of this, it was supposed to be done quite some time ago?

comment:9 Changed 4 years ago by swingit

The code is written, grammar updated. To be tested. Needed to restore Rasdaman installation because of an error in updating repository. Just recovered from it. The patch will be submitted soon.

Last edited 4 years ago by swingit (previous) (diff)

comment:10 Changed 4 years ago by dmisev

The patch still hasn't been applied?

comment:11 Changed 4 years ago by dmisev

  • Milestone changed from 8.5 to 8.5.1

I'm setting this to milestone 8.5.1 - end of August, let's please close it by then.

comment:12 Changed 4 years ago by pbaumann

the patch has some issues, unfortunately, and needs extra effort from our side to close it. Indeed, should be closed soon.

comment:13 Changed 3 years ago by dmisev

  • Milestone changed from 8.5.1 to 9.0
  • Owner changed from swingit to dmisev
  • Priority changed from minor to critical

I can't find this patch in the patchmanager, can someone attach here?

comment:14 Changed 3 years ago by dmisev

  • Status changed from assigned to accepted

Ok I submitted patch.

comment:15 Changed 3 years ago by pbaumann

  • Resolution set to fixed
  • Status changed from accepted to closed

patch is in.

Note: See TracTickets for help on using tickets.