Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#334 closed defect (fixed)

rasimport segmentation fault in RC2

Reported by: ungarj Owned by: ungarj
Priority: critical Milestone: 8.4
Component: rasgeo Version: 8.4
Keywords: Cc:
Complexity: Medium

Description

Just found out that rasimport in 8.4-rc2 causes a segmentation fault when attempting to create a new cube:

command used:

rasimport -d test/ -coll test -3D top -shift 0:0:150500 -csz 1

Same command with same data worked on 8.4-rc1 though.

TIFFs used for testing are attached.

Regards, Joachim

Attachments (1)

test.zip (1.6 KB) - added by ungarj 4 years ago.
import test data

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by ungarj

import test data

comment:1 Changed 4 years ago by dmisev

I'm inclined to think it's a bug in the RPM building.

comment:2 Changed 4 years ago by dmisev

Make sure that on the machine where you build the rasdaman RPMs there is regular GDAL installed, not GDAL built with rasdaman support.

If you can provide a stacktrace with gdb, that might be also helpful.

comment:3 Changed 4 years ago by abeccati

Please make sure that the RPM are built against the same GDAL lib version distributed on the RPM repo

comment:4 Changed 4 years ago by abeccati

  • Owner changed from dmisev to ungarj
  • Status changed from new to assigned

comment:5 Changed 4 years ago by dmisev

No, please make sure rasdaman is built against vanilla GDAL.

comment:6 Changed 4 years ago by ungarj

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks for the hint! I recompiled rasdaman with the appropriate GDAL version and the problem seems to be solved.

Cheers, Joachim

comment:7 Changed 4 years ago by ungarj

some additional information: I did not backtrace the problem in detail but as Dimitar already stated it seems rasdaman has to be built against the same GDAL version.

With rc2-2 GDAL 1.7.3 from EPEL was used, for rc2-3 we used now GDAL 1.9.0 from eox-testing for compiling.

Therefore it is recommended to also use GDAL from the EOX repo when installing the rasdaman RPMs.

Note: See TracTickets for help on using tickets.