Opened 5 years ago

Closed 5 years ago

#285 closed defect (fixed)

WCPS going through PetascopeInterface fails

Reported by: dmisev Owned by: arezaeim
Priority: critical Milestone: 8.4
Component: petascope Version: 8.3
Keywords: Cc: pcampalani, abeccati
Complexity:

Description (last modified by dmisev)

WCPS requests going through the general petascope servlet fail, it seems that the coverages are not loaded from the database.

 TRACE [14:36:22] CoverageIterator@64:   coverage reference : NN3_1
 ERROR [14:36:22] PetascopeInterface@389: Runtime error : null
 ERROR [14:36:22] PetascopeInterface@435: Error stack trace:
RuntimeError: Runtime error while processing request
        at petascope.PetascopeInterface.doGet(PetascopeInterface.java:390)
        at petascope.PetascopeInterface.doPost(PetascopeInterface.java:213)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:602)
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
        at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.NullPointerException
        at petascope.wcps.server.core.CoverageIterator.<init>(CoverageIterator.java:65)
        at petascope.wcps.server.core.XmlQuery.startParsing(XmlQuery.java:103)
        at petascope.wcps.server.core.ProcessCoveragesRequest.<init>(ProcessCoveragesRequest.java:94)
        at petascope.wcps.server.core.Wcps.pcPrepare(Wcps.java:120)
        at petascope.wcps.server.core.Wcps.pcPrepare(Wcps.java:114)
        at petascope.PetascopeInterface.handleProcessCoverages(PetascopeInterface.java:632)
        at petascope.PetascopeInterface.doGet(PetascopeInterface.java:354)
        ... 15 more

It works fine sending WCPS requests to the dedicated WCPS servlet, e.g. http://localhost:8080/petascope/wcps

To reproduce try:

wget --post-data='query=for c in (mr) return AvG(c)' http://localhost:8080/petascope

working

wget --post-data='query=for c in (mr) return AvG(c)' http://localhost:8080/petascope/wcps

Change History (3)

comment:1 Changed 5 years ago by dmisev

  • Description modified (diff)

comment:2 Changed 5 years ago by dmisev

The WCPS tests are executed on http://localhost:8080/petascope/wcps that's why we haven't noticed this.

comment:3 Changed 5 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.