Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#224 closed defect (fixed)

Petascope WCS returns invalid GetCapabilites response

Reported by: dmisev Owned by: dmisev
Priority: critical Milestone: 8.4
Component: petascope Version: 8.3
Keywords: Cc: pbaumann, pcampalani, j.yu, mdumitru
Complexity: Medium

Description

Errors when validating the returned document

cvc-complex-type.2.4.a: Invalid content was found starting with element 'crs:CrsMetadata'. One of '{"http://www.opengis.net/wcs/2.0":formatSupported}' is expected. [82] 

cvc-complex-type.2.4.a: Invalid content was found starting with element 'Wgs84BoundingBox'. One of '{"http://www.opengis.net/ows/2.0":BoundingBox, "http://www.opengis.net/ows/2.0":Metadata}' is expected. [4,328] 

Attachments (1)

capabilities.xml.tar.gz (15.5 KB) - added by dmisev 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by dmisev

comment:1 Changed 4 years ago by dmisev

Piero, is this something that is possibly fixed in your patch?

comment:2 Changed 4 years ago by dmisev

  • Cc mdumitru added

Alex, the formatSupported is introduced in 2.0.1, but you said that you've checked WCS and it already conforms to 2.0.1?

comment:3 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

Submitted patch

comment:4 Changed 4 years ago by dmisev

  • Complexity set to Medium
  • Milestone set to 8.4
Note: See TracTickets for help on using tickets.