Opened 5 years ago

Closed 5 years ago

#220 closed task (fixed)

Check that GML and WCS adhere to the new versions

Reported by: mdumitru Owned by: mdumitru
Priority: major Milestone:
Component: petascope Version:
Keywords: GML, WCPS Cc: vmerticariu, j.yu
Complexity:

Description


Change History (5)

comment:1 Changed 5 years ago by mdumitru

  • Status changed from new to accepted

For GML these should be addressed:
req 1, referring to section 6.4, 6.7
WCSUtil.java, line 162 needs field DataRecord?

req 3, add support for different format encodings
currently supported MIME_GML and not multipart requests

req 6, correct definition of element “metadata” in coverage.xsd
3.2.1 version minOccurs=”0” in sequence elements needs to be removed
processContents = “lax” doesn’t exist, probably fixed

comment:2 Changed 5 years ago by dmisev

  • Summary changed from Check that GML and WCPS adhere to the new versions to Check that GML and WCS adhere to the new versions

My patches fix validation against http://schemas.opengis.net/wcs/2.0/ not sure if that's the latest though.

comment:3 Changed 5 years ago by mdumitru

The patch has been applied, Jinsongdi was notified so he can check it using the conformance tests he devised.
Will close once Jinsongdi gives the greenlight.

comment:4 Changed 5 years ago by dmisev

  • Cc j.yu added

comment:5 Changed 5 years ago by pbaumann

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.