Opened 5 years ago

Closed 4 years ago

#217 closed defect (fixed)

NETCDF export broken - file has incorrect orientation

Reported by: olcl@… Owned by: mrusu
Priority: minor Milestone: 8.4
Component: conversion Version: 8.3
Keywords: Cc:
Complexity:

Description

when exporting data in the NetCDF format the resulting image is rotated incorrectly. However the same data when exported in either PNG of GeoTIFF is correctly orientated.

the query below is used to generate the image and example output files are included.

you can run this query at http://earthserver.pml.ac.uk/petascope/wcps, by replacing the tiff with netcdf or png you can test the other format images.

for c in (myocean_test)
return
encode (
c[t(29)], "tiff"
)

We are using the latest RPM's, version 8.3.1-0.el6

Attachments (1)

38.png (307.7 KB) - added by olcl@… 5 years ago.
screen shot showing difference between png and netcdf output

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by olcl@…

screen shot showing difference between png and netcdf output

comment:1 Changed 5 years ago by pbaumann

  • Owner changed from pbaumann to mrusu
  • Status changed from new to assigned

comment:2 Changed 4 years ago by dmisev

When I look at the file produced by this query now with ncview, it looks pretty messed up:

for c in (myocean_test)
return
encode (
c[t(29)], "netcdf"
)

comment:3 Changed 4 years ago by olcl@…

The latest version of petascope from the new EOX repository fixes this bug and NetCDF output is correctly orientated.

For reference the version with the fix is :

Installed Packages
rasdaman.x86_64 8.3.1-3.el6 @eox-testing
rasdaman-debuginfo.x86_64 8.3.1-3.el6 @eox-testing
rasdaman-devel.x86_64 8.3.1-3.el6 @eox-testing
rasdaman-docs.noarch 8.3.1-3.el6 @eox-testing-noarch
rasdaman-examples.noarch 8.3.1-3.el6 @eox-testing-noarch
rasdaman-petascope.noarch 8.3.1-3.el6 @eox-testing-noarch
rasdaman-rasdaview.x86_64 8.3.1-3.el6 @eox-testing
rasdaman-rasgeo.x86_64 8.3.1-3.el6 @eox-testing

comment:4 Changed 4 years ago by dmisev

In the latest petascope it's fixed because we are now using the rasql encode function; the netcdf function still needs to be fixed.

comment:5 Changed 4 years ago by abeccati

  • Milestone set to 8.4

To reporter, please verify and let us know if this can be marked as resolved, thanks.

comment:6 Changed 4 years ago by olcl@…

Hi Alan,

as far as i am concerned this is fixed with the introduction of the Encode function. however Dimitar has commented above saying it still needs fixing in the netcdf function. so i will leave it up to him to decide if its closed.

comment:7 Changed 4 years ago by abeccati

  • Owner changed from mrusu to dmisev
  • Priority changed from major to minor

Thank you Olly.

Dimitar, please check whether to close, reassign or open another ticket. I've lowered priority since problem has been solved for the user anyway.

comment:8 Changed 4 years ago by dmisev

  • Owner changed from dmisev to mrusu

It's not fixed yet, can be reproduced by

rasql -q 'select netcdf(c[29,*:*,*:*]) from myocean_test as c'

comment:9 Changed 4 years ago by mrusu

Most likely caused by the precedence of latitude over longitude in netcdf dimensions. By the way, even if ncview shows a rotated image, the values on the axes are correct, the lower left corner being denoted as (0, 0) and the higher right as (max_x, max_y). As far as I know, netcdf() will be deprecated in favor of encode(), also on the server side.

comment:10 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from assigned to closed

Oki, let's close.

Note: See TracTickets for help on using tickets.