Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#194 closed defect (wontfix)

WCPS generalCondenseExpr syntax not recognised

Reported by: mase@… Owned by: dmisev
Priority: major Milestone: 8.4
Component: petascope Version: 8.3
Keywords: Cc:
Complexity:

Description

The query

for v1 in (glasgow_witi_t)
return
condense +
over px x(0:100),

py y(0:100)

using 1

gives a runtime error: error translating abstract WCPS query to XL format.

Using RPM 8.3.0-7.el6

Attachments (1)

trac194.log (3.0 KB) - added by mase@… 5 years ago.
Tomcat Log

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by mase@…

Tomcat Log

comment:2 Changed 5 years ago by dmisev

  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopened, the problem is that variables in petascope are required to start with a '$', whereas in the WCPS standard they are not.

comment:3 Changed 4 years ago by pbaumann

  • Resolution set to wontfix
  • Status changed from reopened to closed

This generality (ie, leaving out the $ prefix for variable identification) will have to be abandoned when uniting WCPS with XQuery, so in future the $ will be mandatory anyway.

comment:4 Changed 4 years ago by abeccati

There is more relevant ticket to be used as reference for $ involving issues (see #303).

Note: See TracTickets for help on using tickets.