Opened 3 months ago

Closed 3 months ago

#1581 closed defect (fixed)

rasdaman update fails

Reported by: pbaumann Owned by: bphamhuu
Priority: critical Milestone: 9.5
Component: build system Version: development
Keywords: Cc: dmisev
Complexity: Medium

Description

situation: older rasdaman installation exists (9.x)
effect:

  • downloaded fresh install.sh, running it with option 0 (default)
  • package installation etc fine
  • finally, python script error:
    Preparing Rasdaman SQLite database...
    Database exists already so it was not re-created.
    Rasdaman SQLite database was prepared.
    Preparing petascope...
    Petascope was prepared.
    Rasdaman prepared successfully.
    Finalizing installation...
    Moving rasdaman installer into rasdaman main path...
    Traceback (most recent call last):
      File "/tmp//rasdaman-installer/main.py", line 125, in <module>
        main()
      File "/tmp//rasdaman-installer/main.py", line 114, in main
        str(e.command), str(e.return_code), str(e.stderr), str(e.stdout)))
      File "/usr/lib/python2.7/logging/__init__.py", line 1178, in error
        self._log(ERROR, msg, args, **kwargs)
      File "/usr/lib/python2.7/logging/__init__.py", line 1271, in _log
        self.handle(record)
      File "/usr/lib/python2.7/logging/__init__.py", line 1281, in handle
        self.callHandlers(record)
      File "/usr/lib/python2.7/logging/__init__.py", line 1321, in callHandlers
        hdlr.handle(record)
      File "/usr/lib/python2.7/logging/__init__.py", line 749, in handle
        self.emit(record)
      File "/tmp/rasdaman-installer/helper/log.py", line 48, in new
        history.log_to_history(args[1].levelname, args[1].msg)
      File "/tmp/rasdaman-installer/helper/history.py", line 63, in log_to_history
        self.write_history()
      File "/tmp/rasdaman-installer/helper/history.py", line 69, in write_history
        history_contents = fix_newlines(json.dumps(self.history, indent=4))
      File "/usr/lib/python2.7/json/__init__.py", line 250, in dumps
        sort_keys=sort_keys, **kw).encode(obj)
      File "/usr/lib/python2.7/json/encoder.py", line 209, in encode
        chunks = list(chunks)
      File "/usr/lib/python2.7/json/encoder.py", line 434, in _iterencode
        for chunk in _iterencode_dict(o, _current_indent_level):
      File "/usr/lib/python2.7/json/encoder.py", line 390, in _iterencode_dict
        yield _encoder(value)
    UnicodeDecodeError: 'utf8' codec can't decode byte 0xe2 in position 616: invalid continuation byte
    Error in atexit._run_exitfuncs:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/atexit.py", line 24, in _run_exitfuncs
        func(*targs, **kargs)
      File "/tmp/rasdaman-installer/services.py", line 48, in at_exit
        history.write_history()
      File "/tmp/rasdaman-installer/helper/history.py", line 69, in write_history
        history_contents = fix_newlines(json.dumps(self.history, indent=4))
      File "/usr/lib/python2.7/json/__init__.py", line 250, in dumps
        sort_keys=sort_keys, **kw).encode(obj)
      File "/usr/lib/python2.7/json/encoder.py", line 209, in encode
        chunks = list(chunks)
      File "/usr/lib/python2.7/json/encoder.py", line 434, in _iterencode
        for chunk in _iterencode_dict(o, _current_indent_level):
      File "/usr/lib/python2.7/json/encoder.py", line 390, in _iterencode_dict
        yield _encoder(value)
    UnicodeDecodeError: 'utf8' codec can't decode byte 0xe2 in position 616: invalid continuation byte
    Error in sys.exitfunc:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/atexit.py", line 24, in _run_exitfuncs
        func(*targs, **kargs)
      File "/tmp/rasdaman-installer/services.py", line 48, in at_exit
        history.write_history()
      File "/tmp/rasdaman-installer/helper/history.py", line 69, in write_history
        history_contents = fix_newlines(json.dumps(self.history, indent=4))
      File "/usr/lib/python2.7/json/__init__.py", line 250, in dumps
        sort_keys=sort_keys, **kw).encode(obj)
      File "/usr/lib/python2.7/json/encoder.py", line 209, in encode
        chunks = list(chunks)
      File "/usr/lib/python2.7/json/encoder.py", line 434, in _iterencode
        for chunk in _iterencode_dict(o, _current_indent_level):
      File "/usr/lib/python2.7/json/encoder.py", line 390, in _iterencode_dict
        yield _encoder(value)
    UnicodeDecodeError: 'utf8' codec can't decode byte 0xe2 in position 616: invalid continuation byte
    ERROR: The installer returned an error code. The installation might not be valid.
    

Attachments (1)

install_profile.json (777 bytes) - added by pbaumann 3 months ago.

Download all attachments as: .zip

Change History (5)

Changed 3 months ago by pbaumann

comment:1 Changed 3 months ago by bphamhuu

I managed to update the change in rasdaman installer, thanks to Dimitar, the problem is somehow there is an invalid-character of the listed commands with this error:

UnicodeDecodeError: 'utf8' codec can't decode byte 0xe2

@pbaumann: Can you please rerun the installer in your system by running the bash install.sh again? I tried to reproduce this problem but it is quite hard, so I tried to make a simple case which could make the same error for the called method:

 history_contents = fix_newlines(json.dumps(self.history, indent=4))

comment:2 Changed 3 months ago by pbaumann

tried it again an got this:

Preparing Rasdaman SQLite database...
Database exists already so it was not re-created.
Rasdaman SQLite database was prepared.
Preparing petascope...
Petascope was prepared.
Rasdaman prepared successfully.
Finalizing installation...
Moving rasdaman installer into rasdaman main path...
An error has occured while executing this command: cp -v -r /tmp/rasdaman-installer /opt/rasdaman//installer.Check the log at /tmp/rasdaman.install.log for more details.
Preview of the error:
 Return code: 1
 Stderr: cp: cannot create regular file ‘/opt/rasdaman//installer/rasdaman-installer/rasdaman-installer/.installer-source/rasdaman-installer/.git/objects/36/cdb1a2f0fb062360f69e5879612ad7fde7ea54’: Permission denied
cp: cannot create regular file ‘/opt/rasdaman//installer/rasdaman-installer/rasdaman-installer/.installer-source/rasdaman-installer/.git/objects/36/1b184a6ab0530c81d70bab606bed4fed65c1c4�
 Stdout:‘/tmp/rasdaman-installer/retriever/__init__.py’ -> ‘/opt/rasdaman//installer/rasdaman-installer/retriever/__init__.py’
‘/tmp/rasdaman-installer/retriever/retriever.py’ -> ‘/opt/rasdaman//installer/rasdaman-installer/retriever/retriever.py’
‘/tmp/rasdaman-installer/retriever/__init__.pyc’ -> ‘/opt/rasdaman//installer/rasdaman-installer/retriever/__init__.pyc’
‘/tmp/rasdama
ERROR: The installer returned an error code. The installation might not be valid.

seems a permission problem.

PS: See this non-printable: "d65c1c4�"

Last edited 3 months ago by pbaumann (previous) (diff)

comment:3 Changed 3 months ago by bphamhuu

@pbaumann: ok, we managed to fix it in a simple way, can you try again with bash install.sh?

comment:4 Changed 3 months ago by bphamhuu

  • Resolution set to fixed
  • Status changed from new to closed

It seems you could install with installer without a problem, so I close this ticket here.

Note: See TracTickets for help on using tickets.