Opened 10 months ago

Closed 9 months ago

#1383 closed defect (fixed)

Petascope_Support encoded POST WCPS query

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.3
Component: petascope Version: development
Keywords: Cc: dmisev, vmerticariu
Complexity: Easy

Description

there is a WcpsServlet?.java in Petascope which serve for WCPS query (e.g: by accessing in address http://localhost:8080/rasdaman/ows/wcps and paste the query in the first text box) or using Python to make a POST request to this Servlet.

The problem is it only support the plain WCPS query now, example:

for c in (mr) return encode (c[i(0:20),j(0:20)] + 5, "png")

instead of encoded WCPS query (which is needed in Python POST request by urllib library).

for%20c%20in%20(mr)%20return%20encode%20(c%5Bi(0%3A20)%2Cj(0%3A20)%5D%20%2B%205%2C%20%22png%22)

This problem will needed in case of big WCPS query which has more characters than GET request can support and user will need to change to POST request which can be encoded (i.e by Python library).

The fix is just need to decode the query before send to WCPS parser ( which is only support the plain WCPS query).

Change History (1)

comment:1 Changed 9 months ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.