Opened 10 months ago

Closed 5 months ago

#1340 closed defect (fixed)

Source MDD domain is not within target update MDD domain.

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.3
Component: rasql Version: development
Keywords: Cc: dmisev, mdumitru, vmerticariu, pbaumann
Complexity: Medium

Description

This problem happens when using WCST_Import 2 or more coverage with different extends. It looks like there is a bug in Petascope to open the extend for containing both of these imported coverages, but it makes Rasql has error.
Run the recipe in the attachment file to reproduce the error

Running
Progress: [###############---------------] 1/2 50.00% 
Exception thrown when trying to insert slice: 
{Axis Subset: Lat(-39.66,-34.54) Long(147.2,152.32) 
Data Provider: file:///home/rasdaman/error_update/test2x.tif}
Retrying, you can safely ignore the warning for now. Tried 1 times.

Progress: [###############---------------] 1/2 50.00% 
Failed to insert slice. Attempted 1 times.
Service Call: http://localhost:8080/rasdaman/ows?service=WCS&version=2.0.1&request=UpdateCoverage&coverageId=test1111&subset1=Lat(-39.665,-34.535)&inputCoverageRef=file:///tmp/d31f15f7_2849_4584_bd6f_918e39e99464.gml&subset2=Long(147.205,152.315)
Error Code: RasdamanError
Error Text: <?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<ows:ExceptionReport version="2.0.0"
    xsd:schemaLocation="http://www.opengis.net/ows/2.0 http://schemas.opengis.net/ows/2.0/owsExceptionReport.xsd"
    xmlns:ows="http://www.opengis.net/ows/2.0" xmlns:xsd="http://www.w3.org/2001/XMLSchema-instance" xmlns:xlink="http://www.w3.org/1999/xlink">
    <ows:Exception exceptionCode="RasdamanError">
        <ows:ExceptionText>rasdaman error 967: Update error 967 in line 1, column 1, near token UPDATE: Source MDD domain is not within target update MDD domain.
</ows:ExceptionText>
    </ows:Exception>

</ows:ExceptionReport>


Here is what happened in Rasql from Petascope log,is anything wrong?

Executing query CREATE COLLECTION test1113 GreySet

INSERT INTO test1113 VALUES <[0:0,0:0] 0c> TILING ALIGNED [0:500, 0:500]

/home/rasdaman/install/bin/rasql --user rasadmin --passwd rasadmin -q '
UPDATE test1113 SET test1113[0:885,0:710] 
ASSIGN shift(decode($1), [0,0]) WHERE oid(test1113) = 166913' 
--file '/home/rasdaman/error_update/test2.tif'

/home/rasdaman/install/bin/rasql --user rasadmin --passwd rasadmin -q '
UPDATE test1113 SET test1113[704:806,512:612] 
ASSIGN shift(decode($1), [704,512]) 
WHERE oid(test1113) = 166913'
 --file '/home/rasdaman/error_update/test2x.tif'

 PetascopeInterface@516: Error stack trace:
RasdamanError: rasdaman error 967: 
Update error 967 in line 1, column 1, near token UPDATE: 
Source MDD domain is not within target update MDD domain.

Attachments (1)

error_update.zip (572.6 KB) - added by bphamhuu 10 months ago.

Download all attachments as: .zip

Change History (8)

Changed 10 months ago by bphamhuu

comment:1 Changed 5 months ago by bphamhuu

  • Resolution set to wontfix
  • Status changed from new to closed

actually, my error_recipe here is not correct because they have different resolutions (1 is 0.05x0.05 and 1 is 0.01x0.01) then it will have the wrong calculation.

it is the same problem with Mario in this thread https://groups.google.com/forum/#!topic/rasdaman-users/OFuT_hkk_Iw when his sample coverages are different resolution (pixel size).

File 1:

Size is '''10098, 6134'''
Coordinate System is:
GEOGCS["WGS 84",
    DATUM["WGS_1984",
        SPHEROID["WGS 84",6378137,298.257223563,
            AUTHORITY["EPSG","7030"]],
        AUTHORITY["EPSG","6326"]],
    PRIMEM["Greenwich",0],
    UNIT["degree",0.0174532925199433],
    AUTHORITY["EPSG","4326"]]
Origin = (16.163371686385794,54.237604720050214)
Pixel Size = ('''0.000375671981114,-0.000375671981114''')

File 2:

Size is '''9830, 6193'''
Coordinate System is:
GEOGCS["WGS 84",
    DATUM["WGS_1984",
        SPHEROID["WGS 84",6378137,298.257223563,
            AUTHORITY["EPSG","7030"]],
        AUTHORITY["EPSG","6326"]],
    PRIMEM["Greenwich",0],
    UNIT["degree",0.0174532925199433],
    AUTHORITY["EPSG","4326"]]
Origin = (15.752266195061656,52.775737176349708)
Pixel Size = ('''0.000354628735358,-0.000354628735358''')

So the requirement for extend coverage http://www.rasdaman.org/wiki/PartialUpdates is all the coverages must have same resolution (pixel size).

comment:2 Changed 5 months ago by vmerticariu

Great work Bang! Please let Mario know as well. A solution for him could be to either get data with the same resolution, or use separate coverages for the scenes.

comment:3 follow-up: Changed 5 months ago by dmisev

Can we detect that the resolution is different (on petascope level) and throw a more appropriate error?

Last edited 5 months ago by dmisev (previous) (diff)

comment:4 in reply to: ↑ 3 Changed 5 months ago by bphamhuu

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to dmisev:

Can we detect that the resolution is different and throw a more appropriate error?

I think when Update Coverage in WCST we can do it by comparing with the update GML.

comment:5 Changed 5 months ago by dmisev

  • Owner set to bphamhuu
  • Status changed from reopened to assigned

Give it a try, would be great if that error can be properly captured.

comment:6 Changed 5 months ago by vmerticariu

This should be done in UpdateCoverageValidator?, right now we check that the coverages have the same crses, range types, axes and domains (in case of complete replacement). A similar method that checks that the offset vectors are the same could be added.

comment:7 Changed 5 months ago by bphamhuu

  • Resolution set to fixed
  • Status changed from assigned to closed

close as patch was accepted.

Note: See TracTickets for help on using tickets.