Opened 5 years ago

Closed 5 years ago

#129 closed defect (duplicate)

Error parsing insert TIFF query with inv_tiff()

Reported by: Marcus Sen Owned by:
Priority: major Milestone: 8.4
Component: qlparser Version: 8.3
Keywords: Cc:
Complexity:

Description

Try to load the attached TIFF file using the command below:

rasql -q 'insert into bgs_rs values (RGBPixel) inv_tiff( $1 )' --file bgs_small_ls_test.tif --user rasadmin --passwd ...

I get error:

Executing update query...rasdaman error 300: Parsing error 300 in line 1, column 38: Unexpected name inv_tiff.

and in the log file

Request: 'insert into bgs_rs values (RGBPixel) inv_tiff( #MDD0# )'...parsing...Error: cannot parse query

Attachments (1)

bgs_small_ls_test.tif (2.8 MB) - added by Marcus Sen 5 years ago.
Test TIFF file

Change History (4)

Changed 5 years ago by Marcus Sen

Test TIFF file

comment:1 Changed 5 years ago by anonymous

The insert without cast (RGBPixel) works using the example file /usr/share/rasdaman/petascope/nir.tiff so I guess there is something about our TIFF that can't be dealt with.

comment:2 Changed 5 years ago by Marcus Sen

The error with the cast is a duplicate of ticket:119.

The problem with the file was there was a problem with RGB images without a colour table which should be fixed by changeset:8cfd7a9d512c5ef217a3100c88d37ad397f32eaa .

comment:3 Changed 5 years ago by dmisev

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, so this can be closed.

Note: See TracTickets for help on using tickets.