Opened 5 years ago

Closed 5 years ago

#123 closed enhancement (fixed)

Updating an MDD which intersects with the source array

Reported by: dmisev Owned by: dmisev
Priority: major Milestone: 8.4
Component: qlparser Version: 8.3
Keywords: Cc: pbaumann
Complexity:

Description (last modified by dmisev)

When updating a target MDD T (orange) with a replacement MDD M (red) which intersects T, only the part of T that intersects M will get updated, without materializing the rest and expanding the spatial domain.

This should be fixed to materialize the non-overlapping area as well, accordingly updating the spatial domain.


Attachments (5)

overlap.png (1021 bytes) - added by dmisev 5 years ago.
Ticket_123.tar.gz (2.4 KB) - added by barboni@… 5 years ago.
rasql_1.csv (12.5 KB) - added by barboni@… 5 years ago.
rasql_1.png (699 bytes) - added by barboni@… 5 years ago.
rasql_1.tif (4.3 KB) - added by barboni@… 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by dmisev

comment:1 Changed 5 years ago by dmisev

  • Description modified (diff)

comment:2 Changed 5 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 5 years ago by anonymous

Hello Dimitar

I'm sorry, the ticket #73 can be considered closed but #123 not. The update on a 3D collection currently doesn't work well.

After some update you can observe that the images are non inserted correctly and appears some strange values.
You can reproduce the problem running my attached python script "testKO.py".
the script:

  • generates and initialize a 3d collection named "test";
  • cyclically inserts the same tif image "test10x10.tif" changing shift(x,y) but maintaining a constant z=6;
  • the image is a white square with a black border; If you extract the image you can observe values different than 0 or 255

Materializing the SDOM before start the update works.
The python script "testOK.py" works as the previous but before start update it initialize the space with a black marray: "rasql -q 'insert into test values marray x in[6:6,0:200,0:200] values 0c' --user rasadmin --passwd rasadmin"

It seems that problem happens only when rasdaman try to expand SDOM and the images are overlapped.

Ciao

Damiano

P.S.
I leave this ticket as closed because i don't have permission to reopen.


$ git log

commit dfab54ff153ba4c0093e04d9d4e0db4fe9571115
Author: Dimitar Misev <misev@…>
Date: Fri May 25 13:15:31 2012 +0200

$ gcc -v

gcc version 4.4.4 20100726 (Red Hat 4.4.4-13) (GCC)

Changed 5 years ago by barboni@…

comment:4 Changed 5 years ago by barboni@…

summarizing :
$ python testKO.py
inserd data on non-materialized SDOM and produce the wrong image "testKO.tif"

$ python testOK.py
inserd data on materialized SDOM and produce the correct image "testOK.tif"

damiano

comment:5 Changed 5 years ago by dmisev

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hmm my simple tests with csv output have worked fine, maybe this is some problem with the tif converter, I have to check it.

comment:6 Changed 5 years ago by barboni@…

Ciao Dimitar

The problem for me is not related to the tif converter and in general with data extraction but with the MDD SDOM extension during data insert.

The data extracted in csv and png format present the same problem of tiff images (see attached files).

You can try my simple python script "testKO.py" to insert a series of overlapped images and reproduce the error.

Damiano

Changed 5 years ago by barboni@…

Changed 5 years ago by barboni@…

Changed 5 years ago by barboni@…

comment:7 Changed 5 years ago by dmisev

Damiano, I submitted a patch that should fix this, please verify and let me know.

comment:8 Changed 5 years ago by dmisev

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.