#1181 closed defect (fixed)

Error in GRPC from Petascope

Reported by: bphamhuu Owned by: gmerticariu
Priority: major Milestone: 9.3
Component: rasnet Version: development
Keywords: grpc error Cc: dmisev, mdumitru, atoader
Complexity: Medium

Description

When testing some case in Petascope, I got this problem

http://localhost:8088/rasdaman/ows?service=WCS&version=2.0.1&request=ProcessCoverages&query=for%20c%20in%20(eobstest)%20return%20encode(c[t(%221950-01-03T13:00:00%22),%20Lat(-40.6:-40.5)],%20%22png%22)

Here is error

<ows:ExceptionReport xmlns:ows="http://www.opengis.net/ows/2.0" xmlns:xsd="http://www.w3.org/2001/XMLSchema-instance" xmlns:xlink="http://www.w3.org/1999/xlink" version="2.0.0" xsd:schemaLocation="http://www.opengis.net/ows/2.0 http://schemas.opengis.net/ows/2.0/owsExceptionReport.xsd">
<ows:Exception exceptionCode="SemanticError">
<ows:ExceptionText>
GRPC Exception: Status code:UNAVAILABLE Status description:Connection going away, but for unknown reason Network channel closed
</ows:ExceptionText>
</ows:Exception>
<ows:Exception exceptionCode="RuntimeError">
<ows:ExceptionText>
java.lang.RuntimeException : GRPC Exception: Status code:UNAVAILABLE Status description:Connection going away, but for unknown reason Network channel closed
</ows:ExceptionText>
</ows:Exception>
</ows:ExceptionReport>

Attachments (1)

log_grpc.tar.gz (29.9 MB) - added by bphamhuu 20 months ago.
log here

Change History (9)

Changed 20 months ago by bphamhuu

log here

comment:1 Changed 20 months ago by atoader

Please add to this ticket the queries and data necessary to reproduce the issue. I am guessing you inserted some data prior to trying to process it?

comment:2 Changed 20 months ago by bphamhuu

The query in the top it is embedded WCPS in WCS, the data in system_test ( it is name eobstest, you can go to systemtest/testcase_services/test_wcs/ and run ./test.sh it will ingest data in your system). Regarding with your question, the answer is no, I've executed query early in morning without insert anything from last night.

comment:3 Changed 20 months ago by atoader

Also, to make it easier to check the log output, start rasdaman with only one server and clean the log folder before you reproduce a failing condition.

comment:4 Changed 20 months ago by bphamhuu

yep, if when stop_rasdaman.sh can group the log files to a folder then I will just have the recent log files instead of lot random files name like this (but this is another problem, I will remember your suggestion).

comment:5 Changed 20 months ago by dmisev

Bang I suggested you already to just go to the log directory and use ls -ltr and you'll get the most recent files listed in the bottom. The previous log file names were also random, using the pid in their names.

comment:6 Changed 20 months ago by atoader

  • Owner changed from atoader to gmerticariu
  • Status changed from new to assigned

comment:7 Changed 20 months ago by atoader

As I said before, the log feature will be implemented when we have time. Good debugging practices can be implemented without modifying the code.

comment:8 Changed 14 months ago by bphamhuu

  • Milestone changed from 9.2 to 9.3
  • Resolution set to fixed
  • Status changed from assigned to closed

The problem here can be due to the error of WCPS 1.5 as the subset is minimal (Lat(-40.6,-40.5)) then it translate to wrong interval in grid (e.g: 21:20) and it will have error in Rasql. So with the correct WCPS, it was fixed, close ticket.

Note: See TracTickets for help on using tickets.