#1163 closed defect (wontfix)

NoSuchElementException error in petascope

Reported by: bphamhuu Owned by:
Priority: major Milestone: 9.2
Component: petascope Version: development
Keywords: Cc: mdumitru
Complexity: Medium

Description (last modified by bphamhuu)

I don't know the real problem but I can reproduce by, first installed rasnet (make and make install) then ingest data by wcst_import. Then in petascope rasdaman/ows it can describecoverage normally (using latest patch).

However, using another petascope (./configure without enable rasnet and go straight to application/petascope then make & make install) this error will appear.

 DEBUG [08:25:53] DbMetadataSource@2456: RasQL query : select sdom(c) from rgb AS c where oid(c) = 972801
java.util.NoSuchElementException
	at java.util.StringTokenizer.nextToken(StringTokenizer.java:349)
	at java.util.StringTokenizer.nextToken(StringTokenizer.java:377)

Attachments (1)

log_error_nosuchelement.tar.gz (119.4 KB) - added by bphamhuu 20 months ago.
View log here

Download all attachments as: .zip

Change History (3)

Changed 20 months ago by bphamhuu

View log here

comment:1 Changed 20 months ago by bphamhuu

  • Description modified (diff)

comment:2 Changed 20 months ago by bphamhuu

  • Resolution set to wontfix
  • Status changed from new to closed

I think this problem happen when a petascope not have the library which used by rasnet (e.g: using old petascope with rasnet rasserver), so one upgrade rasdaman will also need to upgrade petascope also.

I will close here as it should be consistent when upgrade.

Note: See TracTickets for help on using tickets.