#1149 closed defect (duplicate)

Error when ingest a coverage same name with existing collection

Reported by: bphamhuu Owned by:
Priority: major Milestone: 9.2
Component: petascope Version: development
Keywords: petascope error, rasnet Cc: dmisev, mdumitru
Complexity: Medium

Description

The problem (test with rasnet) is when I ingest a coverage with wcst_import that is the same name as existing collection which created by

 rasql -q "create collection test_004 QxEhTXYFYvowfrLzoemRAyknjvskgW" --user rasadmin --passwd rasadmin

error in petascope is

[14:44:27] ERROR PetascopeInterface@492: Error stack trace:
RuntimeError: Runtime error while processing request

Caused by: java.util.NoSuchElementException
	at java.util.StringTokenizer.nextToken(StringTokenizer.java:349)

error from wcst_import is

Service Call: http://localhost:8080/rasdaman/ows?service=WCS&version=2.0.1&request=InsertCoverage&coverageRef=file:///tmp/bf64098a_ad1c_4c80_9c0c_ae205ae8a5fc.gml&tiling=ALIGNED [0:500, 0:500]&pixelDataType=UInt16&useId=existing
Error Code: RuntimeError
Error Text: <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ows:ExceptionReport version="2.0.0"
    xsd:schemaLocation="http://www.opengis.net/ows/2.0 http://schemas.opengis.net/ows/2.0/owsExceptionReport.xsd"
    xmlns:ows="http://www.opengis.net/ows/2.0" xmlns:xsd="http://www.w3.org/2001/XMLSchema-instance" xmlns:xlink="http://www.w3.org/1999/xlink">
    <ows:Exception exceptionCode="RuntimeError">
        <ows:ExceptionText>Runtime error while processing request</ows:ExceptionText>
    </ows:Exception>
    <ows:Exception exceptionCode="RuntimeError">
        <ows:ExceptionText>java.util.NoSuchElementException : null</ows:ExceptionText>
    </ows:Exception>

</ows:ExceptionReport>

Change History (1)

comment:1 Changed 21 months ago by mdumitru

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.