#1142 closed defect (fixed)

rasj with rasnet does not properly parse rasdaman collection exists exception

Reported by: mdumitru Owned by: gmerticariu
Priority: major Milestone:
Component: rasnet Version: development
Keywords: Cc:
Complexity: Medium

Description

See this backtrace when running "create collection some_collection" twice with rasj:

RuntimeError: Runtime error while processing request
        at petascope.PetascopeInterface.handleWcs2Request(PetascopeInterface.java:694)
        at petascope.PetascopeInterface.handleWcsRequest(PetascopeInterface.java:575)
        at petascope.PetascopeInterface.doGet(PetascopeInterface.java:355)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:622)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:291)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:239)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:212)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:106)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:502)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:141)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:79)
        at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:616)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:88)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:521)
        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1096)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:674)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1500)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1456)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Thread.java:745)
Caused by: java.util.NoSuchElementException
        at java.util.StringTokenizer.nextToken(StringTokenizer.java:349)
        at rasj.RasQueryExecutionFailedException.<init>(RasQueryExecutionFailedException.java:80)
        at org.rasdaman.rasnet.communication.RasRasnetImplementation.queryRequest(RasRasnetImplementation.java:402)
        at rasj.odmg.RasOQLQuery.execute(RasOQLQuery.java:254)
        at petascope.util.ras.RasUtil.executeRasqlQuery(RasUtil.java:151)
        at petascope.util.ras.RasUtil.createRasdamanCollection(RasUtil.java:459)
        at petascope.wcs2.handlers.wcst.helpers.insert.RasdamanDefaultCollectionCreator.createCollection(RasdamanDefaultCollectionCreator.java:54)
        at petascope.wcs2.handlers.wcst.InsertCoverageHandler.insertGMLCoverage(InsertCoverageHandler.java:173)
        at petascope.wcs2.handlers.wcst.InsertCoverageHandler.handleRemoteCoverageIsert(InsertCoverageHandler.java:120)
        at petascope.wcs2.handlers.wcst.InsertCoverageHandler.handle(InsertCoverageHandler.java:99)
        at petascope.wcs2.handlers.wcst.InsertCoverageHandler.handle(InsertCoverageHandler.java:71)
        at petascope.wcs2.extensions.AbstractProtocolExtension.handle(AbstractProtocolExtension.java:70)
        at petascope.PetascopeInterface.handleWcs2Request(PetascopeInterface.java:645)

Change History (2)

comment:1 Changed 20 months ago by bphamhuu

Some example can see from here http://rasdaman.org/ticket/1149

comment:2 Changed 19 months ago by gmerticariu

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.