Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#113 closed defect (fixed)

wcs2.0.0_req17_postxml

Reported by: j.yu Owned by: erodriguez
Priority: major Milestone: 8.4
Component: petascope Version: 8.3
Keywords: wcs2.0.0 Cc: pbaumann
Complexity: Medium

Description

Req:
Send PostXML DescribeCoverage requests with valid and invalid request structure. Pass test if appropriate valid results or exceptions, resp., are delivered.
Request:
<?xml version="1.0" encoding="UTF-8"?> <wcs:DescribeCoverage xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
xmlns:wcs='http://www.opengis.net/wcs/2.0' xmlns:gml='http://www.opengis.net/gml/3.2' xsi:schemaLocation='http://www.opengis.net/wcs/2.0 ../../wcsAll.xsd'

services="WCS" version="2.0.0"> <wcs:CoverageId>NIR</wcs:CoverageId></wcs:DescribeCoverage>

Result:
[FAILURE] The result should be an ows:ExceptionReport when the request structure is invalid.

Change History (3)

comment:1 Changed 6 years ago by dmisev

  • Cc pbaumann added
  • Owner changed from dmisev to erodriguez
  • Status changed from new to assigned

I've implemented schema validation which would catch such errors, but I think I had to disable it due to errors in the schema. I think re-enabling the validation should fix this ticket, but it may require updating to the latest schemas in petascope.

comment:2 Changed 6 years ago by erodriguez

  • Resolution set to fixed
  • Status changed from assigned to closed

Patch was submitted to add xml validation against schema files.

comment:3 Changed 5 years ago by dmisev

  • Complexity set to Medium
  • Milestone set to 8.4
Note: See TracTickets for help on using tickets.