#1051 closed defect (fixed)

create_db.sh does not work

Reported by: mdumitru Owned by: dmisev
Priority: major Milestone:
Component: undecided Version: development
Keywords: Cc:
Complexity: Medium

Description

On a clean ubuntu 14.04 I get this error:

rasdaman@ubuntu:/opt/rasdaman/install/bin$ ./create_db.sh 
create_db.sh: Creating database, rasdaman v9.0 on base DBMS sqlite
create_db.sh: rasdaman dictionary initialization...\crasdl: rasdaman schema and database manipulation tool, rasdaman v9.1.0-g54a4495 on base DBMS sqlite -- generated on 05.11.2015 07:07:30.
Creating base RASBASE...05/11/2015 07:58:52.880  [INFO] Connected successfully to '/opt/rasdaman/install/data/RASBASE'
05/11/2015 07:58:52.980 [ERROR] SQL query failed: close RASBASE connection
05/11/2015 07:58:52.980 [ERROR] Database warning, code: 5, message: unable to close due to unfinalized statements or unfinished backups
ok
/opt/rasdaman/install/bin/rasdl done.
rasdl: rasdaman schema and database manipulation tool, rasdaman v9.1.0-g54a4495 on base DBMS sqlite -- generated on 05.11.2015 07:07:30.
05/11/2015 07:58:52.986  [INFO] Connected successfully to '/opt/rasdaman/install/data/RASBASE'
Reading rasdaman data definition file /opt/rasdaman/install/share/rasdaman/examples/rasdl/basictypes.dl...inserting symbols into database...ok
ok
/opt/rasdaman/install/bin/rasdl done.
create_db.sh: done.

Change History (6)

comment:1 Changed 18 months ago by dmisev

So did it fail or did it work? The output is quite ambiguous.

comment:2 Changed 18 months ago by mdumitru

Heh, it seems it actually works fine. I saw the error messages and thought it did not create it. We should still see what causes that warning.

comment:3 Changed 18 months ago by dmisev

Yeah failing to close the db connection is normally not an important issue, but it definitely needs to be checked.

comment:4 Changed 18 months ago by dmisev

Patch submitted.

comment:5 Changed 18 months ago by bphamhuu

I can reproduce it (with Centos 7) (before Dimitar's patch) , remove install/data and run create_db.sh when Rasdaman already started. But with his patch, cannot do this anymore.

create_db.sh 
create_db.sh: Creating database, rasdaman v9.0 on base DBMS sqlite
create_db.sh: rasdaman dictionary initialization...\crasdl: rasdaman schema and database manipulation tool, rasdaman v9.1.0-ge9f8ffd on base DBMS sqlite -- generated on 05.11.2015 14:58:23.
Creating base RASBASE...10/11/2015 14:29:10.024  [INFO] Connected successfully to '/home/rasdaman/install/data/RASBASE'
10/11/2015 14:29:15.533 [ERROR] SQL query failed: close RASBASE connection
10/11/2015 14:29:15.533 [ERROR] Database warning, code: 5, message: unable to close due to unfinalized statements or unfinished backups
ok
/home/rasdaman/install/bin/rasdl done.
rasdl: rasdaman schema and database manipulation tool, rasdaman v9.1.0-ge9f8ffd on base DBMS sqlite -- generated on 05.11.2015 14:58:23.
10/11/2015 14:29:15.546  [INFO] Connected successfully to '/home/rasdaman/install/data/RASBASE'
Reading rasdaman data definition file /home/rasdaman/install/share/rasdaman/examples/rasdl/basictypes.dl...inserting symbols into database...ok
ok
/home/rasdaman/install/bin/rasdl done.


comment:6 Changed 18 months ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.